BLS-2019 Operating System Requirements

BLS-2019 program and installer is designed for and officially supports the following operating systems:

  • Windows 10 - Version 1804 "April 2018 Update" - Home, Pro, Enterprise and Education baseline editions
  • Windows 10 - Version 1709 "Fall Creators Update" - Home, Pro, Enterprise and Education baseline editions
  • Windows 10 - Version 1703 "Creators Update"- Home, Pro, Enterprise and Education baseline editions
  • Windows 10 - Version 1607 "Anniversary Update"- Home, Pro, Enterprise and Education baseline editions
  • Windows 10 - Version 1511 "November Update"- Home, Pro, Enterprise and Education baseline editions
  • Windows 10 - Version 1507 "Original Release"- Home, Pro, Enterprise and Education baseline editions
  • Windows 8.1 - Core (non-named edition), Pro, and Enterprise baseline editions
  • Window 8 - Core (non-named edition), Pro, and Enterprise baseline editions
  • Windows 7 - Service Pack 1 - Home Basic, Home Premium, Professional, Enterprise and Ultimate baseline editions.
  • Windows 7 - Original Release-  Home Basic, Home Premium, Professional, Enterprise and Ultimate baseline editions.
  • Windows Server 2016
  • Windows Server 2012 R2
  • Windows Server 2012
  • Windows Server 2008 R2
  • Windows Server 2008
 

BLS-2019 program and installer is not designed for or officially supports the following operating systems:

  • Windows Vista Service Pack 2
  • Windows XP SP3
  • Windows Server 2003 R2
  • Windows Server 2003
While the software may install and operate as designed, there is no guarantee that the software will install or operate or continue to operate. Technical support is not available for programs installed on the listed operating systems. We strongly encourage you to upgrade to a supported operating system. If you are a bowling center using a non-supported operating system with your scoring system, please contact our support team on suggestions.
 

BLS-2019 program and installer is not compatible with following operating systems:

  • Windows RT (The light version of Windows 8 that was an option on non-pro versions of Surface 1 and 2)
  • Windows Vista Service Pack 1
  • Windows Vista initial release
  • Windows XP SP2
  • Windows XP SP1
  • Windows XP initial release
  • Windows 2000
  • Windows Me
  • Windows 98
  • Windows 95
  • Windows NT
  • Apple IOS (iPad, iPhone)
  • Android
  • Chrome OS
  • Apple OS-X Mac Operating Systems (Program can run on Mac hardware using Bootcamp, VMWare Fusion, Parallels Desktop or VirtualBox virtualization solutions with the supported Windows operating system)
  • Linux Operating Systems  (Program can run on Mac hardware using Bootcamp, VMWare Fusion, Parallels Desktop or VirtualBox virtualization solutions with the supported Windows operating system)
Our listing of operating system requirements is subject to change without notice. If you are unsure about compatibility with your operating system, please email our support department.