BTM-5 Operating System Requirements

BTM-5 program and installer is DESIGNED and COMPATIBLE for:

  • Windows 7
  • Windows Vista
  • Windows XP
  • Windows Server 2008
  • Windows Server 2003
 
Important:  Microsoft terminated all support for Windows XP in April 2014.
Windows XP is over 12 years old – which is like 200 years in computer years.  Microsoft is no longer providing any support, bug fixes or security fixes. Because of this, XP will be a strong target for those that create viruses and exploits to obtain access to your information. It is expected to be between 5-10 times more vulnerable to these threats.
The price of computers have fallen so much. 
 
 

BTM-5 program and installer is NOT COMPATIBLE with:

  • Windows XP with Service pack 1 or 2
  • Windows RT (The light version of Windows 8 that works with lower priced tablets)
  • Windows 2000
  • Windows NT
  • Windows Me
  • Windows 98
  • Windows 95
  • IOS (iPad, iPhone)
  • Android
  • Mac Operating Systems (Program can run on Mac hardware using Bootcamp, VMWare Fusion, Parallels Desktop or VirtualBox virtualization solutions with Windows operating system)
  • Linux Operating Systems  (Program can run on Mac hardware using Bootcamp, VMWare Fusion, Parallels Desktop or VirtualBox virtualization solutions with Windows operating system)