Can I open a league from an older BLS that I opened with BLS-2017

No. As in past products, our products are not backwards compatible. When opening a league from a prior BLS in the new BLS, the data will be upgraded and changed appropriately to work with the new program. These changes are not understood by the older versions and data may either no longer be there or migrated to different areas.

Add Feedback