Windows 98, Me, NT or Windows 2000

 Due to many improvements in the software, installer technology and Windows technology and due to Microsoft cutting all product support for Windows prior to Windows XP, we can no longer hold back the capabilities of the software. The installer for BTM-2015 will no longer allow installations on Windows 98, Me or NT or Windows 2000 systems.

Add Feedback