LeagueSecretary.com Website Requirement Changes

On January 1, 2018, LeagueSecretary.com launched a new website that provides new and improved features. It now supports mobile browsers using responsive website technologies as well as direct support for both iOS and Android apps. Performance improvements along with several user requested options have been added such as Excel, CSV and PDF exporting along with logging in using Facebook. Adding leagues to upload has been simplified along with easier and clearer means of managing those uploaded leagues.
 
There have also been improvements made to security, particularly with logins.  Passwords are now CaSe SEnsiTive, so if there are permission issues when uploading, please re-type your password in BLS paying attention to the upper and lower-case letters used.  LeagueSecretary.com will continue to support storage of the most recent two league backup files transmitted during the upload process.
 
Unfortunately, these changes bring new technology that is not compatible with older versions of BLS. In order to take advantage of these improvements and enhancements and continue to upload to LeagueSecretary.com, you must be using BLS-2018 or later. This will become effective in July 31, 2018.
 
Over the years, CDE has always mentioned the importance of upgrading BLS to the latest version to leverage compatibility and improvements through its newsletters. Most recently, announcements were made in their newsletters starting in the summer of 2017 regarding the upcoming new LeagueSecretary.com website and the need to upgrade BLS to support these versions.

Please see below for the steps you should take depending on your version of BLS:
 
  • BLS-2018: No action is needed, but we recommend using version 30.04.05 or higher.
  • BLS-2017: Customers must download and install version 29.08.01 or newer to continue to upload leagues today, but must upgrade to BLS-2018 by July 2018 to continue to upload leagues.
  • BLS-2016: Customers must download and install version 28.08.02 or newer to continue to upload leagues today, but must upgrade to BLS-2018 by July 2018 to continue to upload leagues.
  • BLS-2015: Customers must download and install version 27.09.07 or newer to continue to upload leagues today, but must upgrade to BLS-2018 by July 2018 to continue to upload leagues.
  • BLS-2014 and earlier: Customers must upgrade to BLS-2018 now to continue to upload leagues.
 

Notes:

Bowling centers with A/S editions

Running BLS on:
  • Windows 10 - BLS-2018 is officially supported
  • Windows 8 - BLS-2018 is officially supported
  • Windows 7 - BLS-2018 is officially supported
  • Windows 2012 Server - BLS-2018 is officially supported
  • Windows 2008 Server - BLS-2018 is officially supported
     
  • Windows Vista – Not officially supported, however customers with SP1 installed have been operating BLS-2018.
  • Windows XP - Not officially supported, however customers with SP3 installed have been operating BLS-2018.
  • Windows 2003 Server -  - Not officially supported, however customers have been operating BLS-2018.
 
Options for centers running BLS-2018 on Windows Vista, Windows XP or Windows 2003 server:​
  • Download the installer for BLS-2018 and run the installer, indicating NO to the option to copy leagues from a prior BLS.  Then run BLS-2018, open the demo league and try printing a standing sheet and recap sheet along with generally checking out each screen.  If you are able to do this, then you can operate BLS-2018 and can call CDE to purchase.
  • Network a laptop or simple desktop computer that has Windows 7 or newer to the scoring system network so that it can see the front desk (or in some scoring systems, the server). For ease of use, we usually recommend change the user name and password of this computer to match what is used for the administrator of the front desk (or server, if the case).
    To test, you can install a copy of your existing BLS and then restore a backup made from the original BLS computer to the new one.  Settings in BLS regarding autoscoring paths may need to be configured, but assuming the networking was done correctly and the paths set correctly, BLS on the new computers should export to the front desk (or server if the case) and work.  BLS-2018 should then work fine on this new separate computer.
  • Check with your electronic scoring manufacturer regarding upgrade options for the scoring to move to a supported version of Windows.
Bowling centers with the A/S edition can contact CDE's A/S support at 206-937-5744 for more information about this change and to go over options available to you.
 

League Secretaries or Bowling centers with editions marked Standard or Professional

Running BLS on:
  • Windows 10 - BLS-2018 is officially supported
  • Windows 8 - BLS-2018 is officially supported
  • Windows 7 - BLS-2018 is officially supported
     
  • Windows Vista – Not officially supported, however customers with SP1 installed have been operating BLS-2018.
  • Windows XP - Not officially supported, however customers with SP3 installed have been operating BLS-2018.
  • Windows 2003 Server -  - Not officially supported, however customers have been operating BLS-2018.
League Secretaries or bowling centers with editions marked Standard or Professional can call 206-937-8927 or email help@cdesoftware.com with your questions regarding this change.

Add Feedback