Can I use a newer edition of the MBD with an older edition of BLS or BTM?

No.  Due to changes in the database that may happen, the older products are not aware of or compatible with the changes made in the new database.
 

Add Feedback